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Outline Numbering

Numbering system – lots of themNumbering system – lots of them

1.Number styles

2.User Defined Number Ranges

3.Outline Numbering

Use “Outline Numbering” for your headings Use “Outline Numbering” for your headings 
(anything else is just too hard to deal with)(anything else is just too hard to deal with)
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Turn On Outline Numbering

Tools -> Outline NumberingTools -> Outline Numbering

Level 1-10
(all)

Number
1, 2, 3

After: <dot><space>
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The Basic Document

Use styles Heading1 – Heading10 for headsUse styles Heading1 – Heading10 for heads

Enter some text, watch the numbers.Enter some text, watch the numbers.



Made with OpenOffice.org 5

Figure Numbering

Number styles work, but you can't cross reference Number styles work, but you can't cross reference 
them.them.

Use number range for figures.Use number range for figures.

Insert => Fields => OtherInsert => Fields => Other

Variables TabVariables Tab

Name => FigureName => Figure

Click Click InsertInsert..



Made with OpenOffice.org 6

Defining the Number Range

Variables

Number
Range

Name:
Figure

Insert
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Cross References Must Be Named

Highlight “Figure 1.”Highlight “Figure 1.”

Insert => Cross ReferenceInsert => Cross Reference

Type => Set ReferenceType => Set Reference

Name => NiceFigure (make up your own)Name => NiceFigure (make up your own)

Click InsertClick Insert
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Naming a Cross Reference

Set Reference Name: Nice Figure



Made with OpenOffice.org 9

Referencing the Figure

Add the text “We wish to reference:...”Add the text “We wish to reference:...”

Insert -> Cross Reference Insert -> Cross Reference 

Type -> Insert ReferenceType -> Insert Reference

Select -> NiceFigureSelect -> NiceFigure

Format -> ReferenceFormat -> Reference
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Insert
Reference

Select Reference name Reference
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Insert Table Of Contents

Insert => Indicies and Tables => Indicies and Insert => Indicies and Tables => Indicies and 
TablesTables

Type: Table of Contents
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Defining a Paragraph Code Style

F11 => Brings up style organizerF11 => Brings up style organizer

Use “Text Body” as the base styleUse “Text Body” as the base style

Right click => Right click => NewNew..

Organizer Tab.  Name => Organizer Tab.  Name => CodeCode..

Font Tab.  Font => Font Tab.  Font => CourierCourier
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Defining a Paragraph Code Style

Numbering Tab.  Numbering Tab.  

Numbering style => Numbering1.

Check Restart at this Paragraph.

Background Tab.  Select gray background.Background Tab.  Select gray background.

Borders Tab.  Select Black outside border.Borders Tab.  Select Black outside border.
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Restart Numbering

To restart numbering (at the beginning of a new To restart numbering (at the beginning of a new 
listing)listing)

1.Format => Paragraph.

2.Numbering Tab.  Check Restart at This Paragraph 
and select 1 for Start Width.
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Headers and Footers

Insert => Header => Default Insert => Header => Default 

Insert a header.

Insert => Footer => DefaultInsert => Footer => Default

Insert a footer

To include a page number in the header or footer: To include a page number in the header or footer: 
Insert => Field => Page Number.Insert => Field => Page Number.



Made with OpenOffice.org 16

Working With Others

To keep track of changes: To keep track of changes: 

Identify yourself through Tools => Options.  
OpenOffice group, User Data panel.  Input your user 
name.
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Working With Others

Turn on change recording:Turn on change recording:

Edit => Changes => Record.
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WARNING: Know when to turn it off

Frequent graphic oriented changes.Frequent graphic oriented changes.

All old graphics are saved in the file.

Files can grow quite large.

Old embarrassing text remains if track changes Old embarrassing text remains if track changes 
was on.was on.

Turning it off does not remove old changes.  

Need too “Accept or Reject” changes before they 
disappear.
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Exchanging Comments

Define a Comment paragraph style.  Define a Comment paragraph style.  

Magenta Background

Blue Foreground

Such paragraph are easy for editors and writers to Such paragraph are easy for editors and writers to 
see.  And the colors make them want to take them see.  And the colors make them want to take them 
out.out.

Also put ## on each comment line for easy Also put ## on each comment line for easy 
searching.searching.

## That sort of thing get noticed
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Graphics Files

Editors want screen shots and other graphics in a Editors want screen shots and other graphics in a 
separate file.  separate file.  

OpenOffice files are just ZIP files. OpenOffice files are just ZIP files. 

Unzip a OpenOffice writer document and the Unzip a OpenOffice writer document and the 
graphics are in the directory:graphics are in the directory:

Pictures/generated-name
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Page Styles

Book layout:Book layout:

First page of each chapter starts ½ way down the 
page.  No header / footer.

Left pages have book title on the left side

Right pages have book title on the right side.
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Page Layout

Blah blah blah and more 
blah. Blah blah blah and 
more blah. Blah blah blah 
and more blah. Blah blah

 blah and more blah. Blah 
blah blah and more blah. 
Blah blah blah and more 
blah. Blah blah blah and 
more blah. Blah blah blah 

and more blah. Blah blah 
blah and more blah. Blah 
blah blah and more blah. 

TITLE

Blah blah blah and more 
blah. Blah blah blah and 
more blah. Blah blah blah 
and more blah. Blah blah

 blah and more blah. Blah 
blah blah and more blah. 
Blah blah blah and more . 

Chapter

Blah blah blah and more 
blah. Blah blah blah and 
more blah. Blah blah blah 
and more blah. Blah blah

 blah and more blah. Blah 
blah blah and more blah. 
Blah blah blah and more 
blah. Blah blah blah and 
more blah. Blah blah blah 

and more blah. Blah blah 
blah and more blah. Blah 
blah blah and more blah. 

TITLE

Page Format =>
First Page

Page Format =>
Left

Page Format =>
Right
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First Page

Put the cursor in the first page.Put the cursor in the first page.

Select Page Styles from the Style WindowSelect Page Styles from the Style Window

Double click “First Page” to modify the first Double click “First Page” to modify the first 
page.page.

Page Styles

First Page
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Edit the Page Format

Right Click on “First Page” and select Modify.Right Click on “First Page” and select Modify.

In the Page tab, modify the top margin (5.5 inches)

Page

Top Margin
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Link to next page

Select the Organizer tab. Select the Organizer tab. 

Next Style = Right Page

Organizer

Next Style =
Right Page
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Modify the Other Page Styles

Modify style “Right Page” and make the next Modify style “Right Page” and make the next 
style “Left Page”.style “Left Page”.

Modify style “Left Page” and make the next style Modify style “Left Page” and make the next style 
 “Right Page” “Right Page”
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Headers and Footers

Insert => Header => Left PageInsert => Header => Left Page

Put the title on the left

Insert => Header => Right PageInsert => Header => Right Page

Put the title on the right
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Creating an Index

Highlight a word to be put in the indexHighlight a word to be put in the index

Insert => Indexes and Tables => Entry

Check “Apply to all similar texts” if you want to 
index this word everywhere.  

Click Insert
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Creating an Index

Entry to add
(automatically entered)

Apply to all similar texts
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Creating the index

After adding all the entries:After adding all the entries:

Go to the end of the document (where you want the 
index).

Insert => Indexes and Tables => Index and Tables

Type = Alphabetical Index

Uncheck “Combine Identical Entries with p or pp”

Check “Combine Entries with -”
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Creating The Index

Alphabetical Index Combine identical entries with p or pp
(unchecked)

Combine with - (checked)
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Resulting Index
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WARNINGWARNING
MicrosoftMicrosoft

Word UsersWord Users
Prepare YourselfPrepare Yourself
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Master Document

Microsoft Word's Master DocumentsMicrosoft Word's Master Documents

A system where multiple files can be combined into 
one group so they can be simultaneously shredded 
together.

OpenOffice Master DocumentsOpenOffice Master Documents

Combines multiple chapters into a single book.

---> It Really Works <---
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Microsoft Word Master Documents

Famous for shredding entire manuscripts.Famous for shredding entire manuscripts.
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OpenOffice Master Documents

They work.  They really really work!They work.  They really really work!
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Creating new Master Document

File => New => Master DocumentFile => New => Master Document

Navigator
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Inserting Documents

Click the Insert Click the Insert ICONICON.  Select File..  Select File.

Select one or more files.Select one or more files.

Insert Icon
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Arranging Files

Drag files up and down to put them in order.Drag files up and down to put them in order.

Drag and Drop to arrange
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We've lost all our numbering

The master document controls the style.The master document controls the style.

Current Heading styles are set to the default (no Current Heading styles are set to the default (no 
number).number).

We need to load the styles from a template.We need to load the styles from a template.

We need a template.We need a template.
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Creating a Template From a Chapter

From a typical chapter:From a typical chapter:

1)File => Template => Save.

2)Enter the name of the template for this book.
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Importing the Styles

Format => Styles => Load.Format => Styles => Load.

Select all check boxes.  Select template.Select all check boxes.  Select template.

Select all check boxes
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Outline Numbering Still Needed

Template does not control outline numbering.  Template does not control outline numbering.  
Still need to turn it on.Still need to turn it on.
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Add a Title Page

Right click on document “one” in the Navigator.Right click on document “one” in the Navigator.

Insert => TextInsert => Text

Insert => Text
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Enter Title Page

Enter the title page information in the text section Enter the title page information in the text section 
at the top.at the top.
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Master Page Usage

Title page has it's own styleTitle page has it's own style

Each chapter begins with “First Page”Each chapter begins with “First Page”

Then “Left”, “Right”, “Left”, “Right”Then “Left”, “Right”, “Left”, “Right”

Page Style is controlled by the master document Page Style is controlled by the master document 
so we have to get creative.so we have to get creative.
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First Pages First 

At the end of the title pageAt the end of the title page

Insert -> Manual Break

Type = Page break

Style = First Page
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Insert Manual Break

Page
Break

Style = First Page
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Fixing the next chapter

Right Click on “two.sxw” and select Insert => Right Click on “two.sxw” and select Insert => 
Text.  Text is inserted just in front of the file.Text.  Text is inserted just in front of the file.

Right Click
Insert =>

Text
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Insert another Page Break 

Put another page break between files Put another page break between files one.sxwone.sxw and  and 
two.sxwtwo.sxw. . 

We need text between We need text between two.sxwtwo.sxw and  and three.sxwthree.sxw and  and 
at the end of the book.  But Right Click => Insert at the end of the book.  But Right Click => Insert 
only inserts before the file.only inserts before the file.

Insert text before Insert text before two.sxwtwo.sxw and  and three.sxwthree.sxw, then , then 
drag the text to below drag the text to below three.sxwthree.sxw. Finally, insert a . Finally, insert a 
real text break between the two files. real text break between the two files. 
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All the pieces

Front Matter
Page Break

Page Breaks

Indices / Back Matter
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Structured Figure Numbers

Our figures are number 1,2,3.  We want 1-1, 2-1, Our figures are number 1,2,3.  We want 1-1, 2-1, 
3-1, etc.3-1, etc.

All we have to do is edit a field containing a All we have to do is edit a field containing a 
“Figure” number range and turn on chapter “Figure” number range and turn on chapter 
numbering.numbering.

All our figures are in sub-documents.  Format All our figures are in sub-documents.  Format 
changes are not reflected in the master.changes are not reflected in the master.

Trick: Put in a Figure number range, edit it, then Trick: Put in a Figure number range, edit it, then 
delete it.delete it.
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Structured Figures

Level 1

Separator -
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Cross File Cross References

Set the Cross Reference in the first file (Example Set the Cross Reference in the first file (Example 
FigOne)FigOne)

In the second file: Insert => Cross References.In the second file: Insert => Cross References.

Insert Reference

Type = Reference

Type name in the Name blank

Nothing shows up in the original document.
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Cross File Cross References

Close sub-documentsClose sub-documents

Update Master document linksUpdate Master document links

Item appears.Item appears.
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Additional Resources

http://documentation.openoffice.org/ http://documentation.openoffice.org/ 
thirdparty.htmlthirdparty.html

OOextras – extra templates and picturesOOextras – extra templates and pictures

OpenClipArt – Free Clip ArtOpenClipArt – Free Clip Art

Oomacros – Library of macrosOomacros – Library of macros

ExtenededPDF (http://www.3bview.com/epdf-home.html)ExtenededPDF (http://www.3bview.com/epdf-home.html)


